"Αν τότε αλλιώς" - Άσκηση 1 - Άρτιος ή περιττός;

Ετικέτες: 
 
Να δημιουργηθεί αλγόριθμος ο οποίος δέχεται ως είσοδο δύο αριθμούς και εμφανίζει για κάθε αριθμό αν είναι άρτιος ή περιττός. Στην περίπτωση που και οι δύο αριθμοί είναι περιττοί εμφανίζει το άθροισμά τους, ενώ στην περίπτωση που και οι δύο αριθμοί είναι άρτιοι εμφανίζει την απόλυτη τιμή της διαφορά τους.
 
Λύση: 
Αλγόριθμος Παράδειγμα_1
Εμφάνισε “ Δώσε δύο αριθμούς… ”
Διάβασε α,β
Αν α mod 2 = 0 τότε
        Αν β mod 2 = 0 τότε
              Εμφάνισε “α άρτιος και β άρτιος”
              Εμφάνισε “Η απόλυτη τιμή της διαφορά των δύο άρτιων αριθμών είναι…”, Α_Τ(α-β)
        Αλλιώς
              Εμφάνισε “α άρτιος και β περιττός”
        Τέλος_αν
Αλλιώς
          Αν β mod 2 = 0 τότε
                 Εμφάνισε “α περιττός και β άρτιος”
          Αλλιώς
                 Εμφάνισε “α περιττός και β περιττός”
                 Εμφάνισε “Το άθροισμα των δύο περιττών αριθμών είναι…”, α+β
          Τέλος_αν
Τέλος_αν
Τέλος Παράδειγμα_1