"Αν τότε αλλιώς" - Άσκηση 4 - Πολλαπλές επιλογές με εμφωλευμένες δομές - Υπολογισμός επιδόματος

 
Για τον υπολογισμό του επιδόματος των εργαζομένων μιας εταιρείας πρέπει να κατασκευάσετε αλγόριθμο ο οποίος:
i. Ρωτάει τον χρήστη αν είναι παντρεμένος ή όχι και αποθηκεύει την απάντηση στην μεταβλητή «επιλογή». Οι αποδεκτές τιμές είναι «Ν» ή «ν» αν ο χρήστης απαντήσει θετικά και «Ο» ή «ο», αν ο χρήστης απαντήσει αρνητικά. Σε περίπτωση που δεν δοθεί μια από τις επιτρεπόμενες τιμές, ο χρήστης πρέπει να εισάγει ξανά την απάντησή του.
ii. Διαβάζει με κατάλληλο μήνυμα τον αριθμό των παιδιών που διαθέτει ο εργαζόμενος και αποθηκεύει την εισαγόμενη τιμή στην μεταβλητή «παιδιά». Θα πρέπει ο χρήστης να πληκτρολογήσει τιμή μεγαλύτερη του 0, σε περίπτωση που αυτό δε συμβεί τότε πρέπει εισάγει ξανά το πλήθος των παιδιών του.
iii. Υπολογίζει και εμφανίζει το επίδομα του εργαζομένου αν ισχύει η παρακάτω πολιτική: Οι παντρεμένοι παίρνουν επίδομα 100 €. Όσοι έχουν πάνω από 3 παιδιά παίρνουν 15 € για κάθε παιδί είτε είναι παντρεμένοι είτε όχι.
 
Λύση: 
Αλγόριθμος Υπολογισμός_επιδόματος
Αρχή_επανάληψης
     Εμφάνισε "Είσαι παντρεμένος;"
     Διάβασε επιλογή
Μέχρις_ότου επιλογή = "Ν" ή επιλογή = "ν" ή επιλογή = "Ο" ή επιλογή = "ο"
Αρχή_επανάληψης
     Εμφάνισε "Πόσα παιδιά έχεις;"
     Διάβασε παιδιά
Μέχρις_ότου παιδιά >= 0
Αν επιλογή = "Ν" ή επιλογή = "ν" τότε
     Αν παιδιά > 3 τότε
          Επίδομα ← 100 + παιδιά*15
     αλλιώς
            Επίδομα ← 100
     Τέλος_αν
αλλιώς
     Αν παιδιά > 3 τότε
            Επίδομα ← παιδιά*15
     αλλιώς
          Επίδομα ← 0
     Τέλος_αν
Τέλος_αν
Εμφάνισε "Το επίδομά σου είναι:", Επίδομα
Τέλος Υπολογισμός_επιδόματος