"Για από μέχρι" - Άσκηση 1 - Κατασκήνωση μαθητών

 
Σε μία κατασκήνωση υπάρχουν 200 παιδιά, ο υπεύθυνος της κατασκήνωσης επιθυμεί να συγκεντρώσει ένα χρηματικό ποσό το οποίο θα διατεθεί για φιλανθρωπικούς σκοπούς. Να δημιουργηθεί αλγόριθμος που δέχεται το χρηματικό ποσό κάθε μαθητή και θα υπολογίζει το χρηματικό ποσό που συγκεντρώθηκε από το σύνολο των μαθητών, το μεγαλύτερο και το μικρότερο ποσό που δόθηκε, καθώς επίσης και το πλήθος των μαθητών που έδωσαν ποσό μεγαλύτερο των 10 €. Όλα τα αποτελέσματα να εμφανίζονται με κατάλληλα μηνύματα.
 
Λύση: 
Αλγόριθμος Έρανος
Πλήθος ← 0               ! πλήθος παιδιών που έδωσαν πάνω από 10 €
άθροισμα ← 0             ! συνολικό ποσό που συγκεντρώθηκε
Εμφάνισε “Δώσε το χρηματικό ποσό”
Διάβασε ποσό
άθροισμα  ← άθροισμα + ποσό
Αν ποσό > 10 τότε
   Πλήθος ← πλήθος + 1
Τέλος_αν
μέγιστο_ποσό ← ποσό                      ! υποθέτουμε ότι το πρώτο ποσό είναι το μέγιστο
μικρότερο_ποσό ← ποσό                   ! υποθέτουμε ότι το πρώτο ποσό είναι και το ελάχιστο
Για i από 2 μέχρι 200                          !Ξεκινάμε με i=2 γιατί έχουμε διαβάσει τον 1ο μαθητή
   Εμφάνισε “Δώσε το χρηματικό ποσό..”
   Διάβασε ποσό                        ! Διαβάζουμε το επόμενο ποσό
   άθροισμα ← άθροισμα + ποσό
   Αν ποσό > 10 τότε
        Πλήθος ← πλήθος + 1
   Τέλος_αν
   Αν ποσό > μέγιστο_ποσό τότε
        μέγιστο_ποσό ←ποσό
   Τέλος_αν
   Αν ποσό < μικρότερο_ποσό τότε
       μικρότερο_ποσό ← ποσό
   Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε “ Το συνολικό ποσό που συγκεντρώθηκε είναι…:”, άθροισμα
Εμφάνισε “ Το μικρότερο ποσό που δόθηκε είναι…”, μικρότερο_ποσό
Εμφάνισε “ Το μεγαλύτερο ποσό που δόθηκε είναι…”, μέγιστο_ποσό
Τέλος Έρανος