Πίνακες - Άσκηση 2 - Υπολογισμός μεγίστου & ελαχίστου μονοδιάστατου πίνακα

 
Να δημιουργηθεί αλγόριθμος ο οποίος θα αποθηκεύει σε κατάλληλες δομές δεδομένων τα ονόματα και τους μισθούς 35 εκπαιδευτικών και θα εμφανίζει το όνομα του εκπαιδευτικού με τις μεγαλύτερες αποδοχές καθώς και το όνομα αυτού με τις μικρότερες.
 
Λύση: 
Αλγόριθμος Μέγιστος_Ελάχιστος_Μισθός
Για i από 1 μέχρι 35
Εμφάνισε “Δώσε όνομα και μισθό του”,i,”εκπαιδευτικού”
Διάβασε όνομα[i],μισθός[i]
Τέλος_επανάληψης
min_μισθός ← μισθός[1]              !Υποθέτουμε ότι ο μικρότερος μισθός είναι ο 1ος
min_όνομα ← όνομα[1] !Αποθηκεύουμε το όνομα του 1ου εκπαιδευτικού με το μικρότερο μισθό
max_μισθός ← μισθός [1]            !Υποθέτουμε ότι ο μέγιστος μισθός είναι ο 1ος 
max_όνομα ← όνομα[1]              ! Αποθηκεύουμε το όνομα του 1ου εκπαιδευτικού με το μεγαλύτερο μισθό
Για i από 2 μέχρι 35                        !Ελέγχουμε τους υπόλοιπους εκπαιδευτικούς
Αν μισθός[i] > max_μισθό τότε                  !Έλεγχος μεγίστου
max_μισθός ← μισθός[i]
max_όνομα ← όνομα[i]
Τέλος_αν
Αν μισθός[i] < min_μισθό τότε                   !Έλεγχος ελαχίστου
min_μισθός ←μισθός[i]
min_όνομα ← όνομα[i]
Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε “Ο εκπαιδευτικός με τις μεγαλύτερες αποδοχές είναι ο”,max_όνομα
Εμφάνισε “Μέγιστες αποδοχές”,max_μίσθος
Εμφάνισε “Ο εκπαιδευτικός με τις μικρότερες αποδοχές είναι ο”,min_όνομα
Εμφάνισε “Μικρότερες αποδοχές”,min_μίσθος
Τέλος Μέγιστος_Ελάχιστος_Μισθός