Πίνακες - Άσκηση 3 - Υπολογισμός μέσου όρου, μέγιστης και ελάχιστης τιμής με χρήση τριών μονοδιάστατων πινάκων

 
Να δημιουργηθεί αλγόριθμος που αποθηκεύει σε κατάλληλες δομές δεδομένων, το όνομα, την ηλικία και το μισθό των 158 εκπαιδευτικών μιας πόλης. Ο αλγόριθμος να εμφανίζει, το μέσο όρο ηλικίας των εκπαιδευτικών, το όνομα και τον μισθό του εκπαιδευτικού με το μεγαλύτερο μισθό καθώς και το όνομα και την ηλικία του εκπαιδευτικού με τη μικρότερη ηλικία.
 
Λύση: 
Αλγόριθμος Εκπαιδευτικοί
sum ← 0
Για i από 1 μέχρι 158
Εμφάνισε “Δώσε το όνομα, την ηλικία και το μισθό του” ,i, “εκπαιδευτικού”
Διάβασε Όνομα[i], Ηλικία[i], Μισθός[i]
Sum← sum +Ηλικία[i]    !Άθροισμα των ηλικιών
Τέλος_επανάληψης
Maxmisthos← Μισθός[1]             !Υποθέτουμε ότι ο 1ος  μισθός του πίνακα «Μισθός» είναι ο μέγιστος
maxname ← Όνομα[1]                  !Επομένως ο εκπαιδευτικός με το μεγαλύτερο μισθό είναι ο Όνομα[1]
minage ←Ηλικία[1]                       !Υποθέτουμε ότι η 1η  ηλικία του πίνακα είναι η μικρότερη, δηλ. η Ηλικία[1]
minname ← Όνομα[1]                   !Επομένως ο εκπαιδευτικός με τη μικρότερη ηλικία είναι ο Όνομα[1]
Για i από 2 μέχρι 158                      !Ελέγχουμε του υπόλοιπους 157 εκπαιδευτικούς
Αν Μισθός[i] > maxmisthos τότε               !Ελέγχουμε για το μεγαλύτερο μισθό
maxmisthos ← Misthos[i]
maxname ← Όνομα [i]
Τέλος_αν
Αν Ηλικία[i] < minage τότε                                           !Ελέγχουμε για τη μικρότερη ηλικία
minage ← Ηλικία[i]
minname ← Όνομα[i]
Τέλος_αν
Τέλος_επανάληψης
MO ←sum/158                                                                 !Υπολογισμός μέσου όρου ηλικίας
Εμφάνισε “Ο μέσος όρος ηλικίας των εκπαιδευτικών είναι ”,MO
Εμφάνισε “Ο”,minname, “έχει τη μικρότερη ηλικία που είναι”,minage
Εμφάνισε “Ο”,maxname ,”έχει τo μεγαλύτερο μισθό που είναι”,maxmisthos
Τέλος Εκπαιδευτικοί