Πίνακες - Άσκηση 4 - Πίνακας με μοναδικές τιμές

 
Να δημιουργηθεί αλγόριθμος που διαβάζει έναν πίνακα 50 θέσεων (ακέραιες τιμές) με την προϋπόθεση ότι στο τέλος, όλα τα στοιχεία του πίνακα να είναι διαφορετικά. Ο αλγόριθμος θα πρέπει:
 
Α. Να ενημερώνει το χρήστη ποια θέση του πίνακα διαβάζεται κάθε φορά.
 
Β. Να διαβάζει το στοιχείο της κάθε θέσης του πίνακα και να αναζητά αν αυτό υπάρχει μέσα στον πίνακα. Σε περίπτωση που αυτό υπάρχει στον πίνακα, να ενημερώνει με μήνυμα σε ποια θέση του πίνακα βρέθηκε και να ξαναδιαβάζει το στοιχείο μέχρι να δοθεί κάποιο που δεν υπάρχει στον πίνακα.
 
Γ. Στην περίπτωση που το στοιχείο δεν υπάρχει στον πίνακα, να ενημερώνει με κατάλληλο μήνυμα ότι μπορεί να τοποθετηθεί στον πίνακα, να τοποθετεί το στοιχείο στο πίνακα και να διαβάζει το επόμενο στοιχείο.
 
Λύση: 
Αλγόριθμος Πίνακας_με_μοναδικές_τιμές
Εμφάνισε "Δώσε αριθμό για την 1η θέση του πίνακα"
Διάβασε Π[1] κ ←  1
Για i από 2 μέχρι 50
Αρχή_επανάληψης
Εμφάνισε " Δώσε αριθμό για την ", i, " θέση του πίνακα"
Διάβασε αρ done ←  Ψευδής pos ←  0
J ←  1
Όσο (done = Ψευδής) και (J <= κ) επανάλαβε
Αν Π[J] = αρ τότε
done ←  Αληθής
pos ←  J
Εμφάνισε "Ο αριθμός υπάρχει στον πίνακα στη θέση:", pos
αλλιώς
J ←  J + 1
Τέλος_αν
Τέλος_επανάληψης
Μέχρις_ότου done = Ψευδής
Εμφάνισε "Ο αριθμός που δώσατε μπορεί να τοποθετηθεί στον πίνακα"
Π[i] ←  αρ κ ←  κ + 1
Τέλος_επανάληψης
Τέλος Πίνακας_με_μοναδικές_τιμές