Προγράμματα - Άσκηση 2 - Στατιστική υπηρεσία

 
Μια στατιστική υπηρεσία αναλαμβάνει να καταχωρήσει τις θερμοκρασίες 10 πόλεων για τον περασμένο μήνα (31 ημέρες). Να αναπτύξετε πρόγραμμα το οποίο:
1. Διαβάζει και αποθηκεύει σε κατάλληλους πίνακες, τα ονόματα των 10 πόλεων καθώς και τις θερμοκρασίες που σημειώθηκαν τον περασμένο μήνα.
2. Βρίσκει και εμφανίζει το πλήθος των πόλεων που είχαν μέση μηνιαία θερμοκρασία μεγαλύτερη των 22 βαθμών κελσίου καθώς και το πλήθος αυτών που είχαν μέση μηνιαία θερμοκρασία 5 βαθμών κελσίου.
3. Να βρίσκει και να εμφανίζει την μέγιστη θερμοκρασία του μήνα, την πόλη και την ημέρα στην οποία σημειώθηκε, εμφανίζοντας σχετικό μήνυμα.
 
Λύση: 
ΠΡΟΓΡΑΜΜΑ ΣΤΑΤΙΣΤΙΚΗ_ΥΠΗΡΕΣΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:I,J,MAXΠΟΛΗ,MAXΗΜΕΡΑ,ΠΛΗΘΟΣ22,ΠΛΗΘΟΣ5
ΠΡΑΓΜΑΤΙΚΕΣ: ΘΕΡΜΟΚΡΑΣΙΑ[10,31],MO,SUM,MAX
ΧΑΡΑΚΤΗΡΕΣ: ΠΟΛΗ[10]
ΑΡΧΗ
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 10
ΓΡΑΨΕ 'ΔΩΣΕ ΤΗΝ ',I, 'η ΠΟΛΗ'
ΔΙΑΒΑΣΕ ΠΟΛΗ[I]
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 31
ΓΡΑΨΕ 'ΔΩΣΕ ΤΗΝ ΘΕΡΜΟΚΡΑΣΙΑ ΤΗΣ',J,'ΗΜΕΡΑΣ'
ΔΙΑΒΑΣΕ ΘΕΡΜΟΚΡΑΣΙΑ[I,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΠΛΗΘΟΣ22 ← 0
ΠΛΗΘΟΣ5 ← 0
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 10
SUM ← 0
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 31
SUM ← SUM + ΘΕΡΜΟΚΡΑΣΙΑ[I,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO ← SUM/31
ΑΝ MO>22 ΤΟΤΕ
ΠΛΗΘΟΣ22 ← ΠΛΗΘΟΣ22 + 1
ΤΕΛΟΣ_ΑΝ
ΑΝ MO=5 ΤΟΤΕ
ΠΛΗΘΟΣ5 ←ΠΛΗΘΟΣ5 + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ