Προγράμματα - Άσκηση 3 - Εύρεση μέσου όρου ανά στήλη και υπολογισμός μεγίστου και θέσης αυτού για συγκεκριμένη στήλη σε δισδιάστατο πίνακα

 
Να κατασκευάσετε πρόγραμμα το οποίο πραγματοποιεί τα παρακάτω:
Α) Διαβάζει τα ονόματα τριών πόλεων και τα τοποθετεί σε μια μονοδιάστατη δομή δεδομένων.
Β) Διαβάζει τις ημερήσιες θερμοκρασίες αυτής της εβδομάδας για τις τρεις πόλεις που έδωσε ο χρήστης και τις τοποθετεί σε μια δισδιάστατη δομή δεδομένων.
Γ) Υπολογίζει και εμφανίζει τη μέση θερμοκρασία που είχαν οι τρεις πόλεις ανά
ημέρα.
Δ) Υπολογίζει τη μέγιστη θερμοκρασία της 4ης ημέρας της εβδομάδας και εμφανίζει το όνομα της πόλης στην οποία παρουσιάστηκε.
 
Λύση: 
ΠΡΟΓΡΑΜΜΑ ΘΕΡΜΟΚΡΑΣΙΑ
            ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:i, j, θέση
            ΠΡΑΓΜΑΤΙΚΕΣ: ΘΕΡΜ[3,7], ΜΟ_ΗΜΕΡΑΣ[7], Sum, Μέγιστο
            ΧΑΡΑΚΤΗΡΕΣ: ΠΟΛΗ[3]
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΟΝΟΜΑ ΤΗΣ',i,'ΠΟΛΗΣ'
ΔΙΑΒΑΣΕ ΠΟΛΗ[I]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
            ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 7
ΓΡΑΨΕ 'ΔΩΣΕ ΤΗΝ ΘΕΡΜΟΚΡΑΣΙΑ ΤΗΣ',ΠΟΛΗ[i],'ΤΗΝ',j,'ΗΜΕΡΑ'
ΔΙΑΒΑΣΕ ΘΕΡΜ[i,j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 7
Sum ← 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
Sum ← sum+ΘΕΡΜ[i,j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ_ΗΜΕΡΑΣ[j] ← Sum/3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
ΓΡΑΨΕ 'Η ΜΈΣH ΘΕΡΜΟΚΡΑΣΙΑ ΤΗΝ', i ,'ΗΜΕΡΑ ΕΙΝΑΙ :', ΜΟ_ΗΜΕΡΑΣ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέγιστο ← ΘΕΡΜ[1,4]
θέση ←1
ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 3
ΑΝ ΘΕΡΜ[i,4]>Μέγιστο ΤΟΤΕ
Μέγιστο ←  ΘΕΡΜ[i,4]
Θέση ←  i
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'Η ΜΕΓΙΣΤΗ ΘΕΡΜΟΚΡΑΣΙΑ ΤΗΝ 4η ΗΜΕΡΑ ΕΙΝΑΙ :',Μέγιστο
ΓΡΑΨΕ 'ΚΑΙ ΠΑΡΟΥΣΙΑΣΤΗΚΕ ΣΤΗΝ ΠΟΛΗ' ,ΠΟΛΗ[θέση]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ