Προγράμματα - Άσκηση 4 - ATM τράπεζας

 
Να κατασκευάσετε πρόγραμμα που προσομοιώνει ένα ATM τράπεζας σύμφωνα με τα παρακάτω χαρακτηριστικά :
α) Το ΑΤΜ Διαβάζει το PIN της κάρτας του πελάτη και ελέγχει αν αυτό συμφωνεί με τον κωδικό της κάρτας. Ο κωδικός της κάρτας είναι πάντα ο αριθμός 123546. Το αρχικό υπόλοιπο της κάρτας είναι 15000€.
β) Αν οι δύο κωδικοί είναι ίδιοι τότε ο χρήστης μπορεί να επιλέξει ένα είδος συναλλαγής , σε αντίθετη περίπτωση εμφανίζεται το μήνυμα “ΔΕΝ ΠΛΗΚΤΡΟΛΟΓΗΣΑΤΕ ΣΩΣΤΟ ΚΩΔΙΚΟ”. Το είδος της συναλλαγής μπορεί να είναι : [1] Ανάληψη ή [2] Κατάθεση.
γ) Αν ο χρήστης επιλέξει ανάληψη (1) τότε το ΑΤΜ διαβάζει το ποσό ανάληψης, ελέγχει το ποσό και το υπόλοιπο του λογαριασμού και εμφανίζει για όλες τις περιπτώσεις κατάλληλα μηνύματα καθώς και το νέο υπόλοιπο του λογαριασμού.
δ) Αν ο χρήστης επιλέξει κατάθεση (2) τότε το ΑΤΜ διαβάζει το ποσό κατάθεσης,
ενημερώνει και εμφανίζει το νέο υπόλοιπο του λογαριασμού του πελάτη.
ε) Στο τέλος κάθε συναλλαγής το ΑΤΜ εμφανίζει κατάλληλο μήνυμα για το αν ο πελάτης επιθυμεί άλλη συναλλαγή. Στην περίπτωση που ο πελάτης επιθυμεί νέα συναλλαγή τότε εισάγει ξανά το PIN της κάρτας του, στην αντίθετη περίπτωση η διαδικασία τερματίζεται.
ζ) Για τα ποσά της κατάθεσης και της ανάληψης γίνεται έλεγχος αν είναι θετικοί αριθμοί, σε περίπτωση λάθος πληκτρολόγησης ο πελάτης ξανά δίνει τα ποσά. Έλεγχος υπάρχει και στο είδος της συναλλαγής που πρέπει να είναι οι αριθμοί 1 ή 2, σε περίπτωση λάθος πληκτρολόγησης ο πελάτης εισάγει ξανά έναν αριθμό.
 
Λύση: 
ΠΡΟΓΡΑΜΜΑ  ΑΤΜ
ΣΤΑΘΕΡΕΣ
CARDCODE=123546
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:PIN,ΕΠΙΛΟΓΗ,Υ, ΠΟΣΟ_Α,ΠΟΣΟ_Κ
ΧΑΡΑΚΤΗΡΕΣ:RESTART
ΑΡΧΗ
Y ← 15000
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ' ΔΩΣΕ TO PIN ΤΟΥ ΠΕΛΑΤΗ'
ΔΙΑΒΑΣΕ PIN
ΑΝ PIN = CARDCODE ΤΟΤΕ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ' ΠΙΕΣΤΕ (1) ΓΙΑ ΑΝΑΛΗΨΗ ΚΑΙ (2) ΓΙΑ ΚΑΤΑΘΕΣΗ '
ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ=1 Η ΕΠΙΛΟΓΗ=2
ΑΝ ΕΠΙΛΟΓΗ=1 ΤΟΤΕ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ' ΔΩΣΕ ΧΡΗΜΑΤΙΚΟ ΠΟΣΟ ΓΙΑ ΑΝΑΛΗΨΗ'
ΔΙΑΒΑΣΕ ΠΟΣΟ_Α
ΜΕΧΡΙΣ_ΟΤΟΥ ΠΟΣΟ_Α>0
ΑΝ ΠΟΣΟ_Α<Y ΤΟΤΕ
Y ←Y-ΠΟΣΟ_Α
ΓΡΑΨΕ' ΝΕΟ ΥΠΟΛΟΙΠΟ ΛΟΓΑΡΙΑΣΜΟΥ ',Y
ΑΛΛΙΩΣ_ΑΝ ΠΟΣΟ_Α>Y ΤΟΤΕ
ΓΡΑΨΕ' ΕΧΕΤΕ ΥΠΕΡΒΕΙ ΤΟ ΟΡΙΟ ΤΟΥ ΛΟΓΑΡΙΑΣΜΟΥ ΣΑΣ '
ΑΛΛΙΩΣ
Y ← 0
ΓΡΑΨΕ' ΝΕΟ ΥΠΟΛΟΙΠΟ ΛΟΓΑΡΙΑΣΜΟΥ ', Y
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
ΓΡΑΨΕ'ΔΕΝ ΠΛΗΚΤΡΟΛΟΓΗΣΑΤΕ ΣΩΣΤΟ ΚΩΔΙΚΟ'
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ 'ΘΕΛΕΤΕ ΑΛΛΗ ΣΥΝΑΛΛΑΓΗ; (Ν/Ο)'
ΔΙΑΒΑΣΕ RESTART
ΜΕΧΡΙΣ_ΟΤΟΥ   RESTART='O'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ