Προγράμματα - Άσκηση 5 - Μείωση αποδοχών

 
Μια επιχείρηση αποφάσισε να προχωρήσει σε μείωση των αποδοχών των 50 υπαλλήλων που απασχολούνται στην επιχείρηση λόγω της οικονομικής κρίσης. Να δημιουργηθεί πρόγραμμα το οποίο:
  • Να περιλαμβάνει τμήμα δηλώσεων.
  • Να καταχωρεί τα ονόματα των 50 υπαλλήλων της επιχείρησης στον πίνακα O, τους μισθούς τους στο πίνακα Μ και τα τέκνα του κάθε υπαλλήλου στον πίνακα Π. Να γίνει έλεγχος των δεδομένων εισόδου για τα τέκνα των υπαλλήλων, με αποδεκτές τιμές μόνο θετικές ή 0.
  • Να δημιουργεί ένα νέο πίνακα ΝΜ με τους νέους μισθούς των υπαλλήλων οι οποίοι θα προκύπτουν από την παρακάτω πολιτική που αποφασίστηκε από την διοίκηση.
Μισθός Μείωση
Μέχρι και 1000 € 4%
Μέχρι και 1500 € 6%
Μέχρι και 2000 € 9%
Πάνω από 2000 € 11%
Αν ο υπάλληλος έχει περισσότερα από 3 παιδιά τότε ο μισθός του παραμένει ως έχει.
  • Να εμφανίζει το όνομα του υπαλλήλου, τις νέες αποδοχές του καθώς και το ποσό της μείωσης. Για την περίπτωση των υπαλλήλων που έχουν περισσότερα από 3 τέκνα να εμφανίζεται το όνομα του υπαλλήλου και το μήνυμα “Πολύτεκνος δεν πραγματοποιήθηκε μείωση αποδοχών”.

 

Λύση: 
ΠΡΟΓΡΑΜΜΑ ΜΕΙΩΣΗ_ΑΠΟΔΟΧΩΝ
ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: i, Π[50]
          ΧΑΡΑΚΤΗΡΕΣ: Ο[50]
          ΠΡΑΓΜΑΤΙΚΕΣ: M[50], NM[50], ΜΕΙΩΣΗ
ΑΡΧΗ
          ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
                    ΓΡΑΨΕ “Δώσε το όνομα του”,i,”υπαλλήλου”
ΔΙΑΒΑΣΕ Ο[i]
ΓΡΑΨΕ “Δώσε τον μισθό του”,i,”υπαλλήλου”
ΔΙΑΒΑΣΕ M[i]
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ “Δώσε αριθμό τέκνων”,i,”υπαλλήλου”
ΔΙΑΒΑΣΕ Π[i]
                    ΜΕΧΡΙΣ_ΟΤΟΥ Π[i]>=0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
                      ΑΝ Π[i]>3 ΤΟΤΕ
                                  NM[i] ß Μ[i]
                      ΑΛΛΙΩΣ
                                  ΑΝ Μ[i] <= 1000 ΤΟΤΕ
ΝΜ[i] Μ[i] - Μ[i]*(4/100)
                                  ΑΛΛΙΩΣ_ΑΝ Μ[i] <= 1500 ΤΟΤΕ
ΝΜ[i] Μ[i] - Μ[i]*(6/100)
                                  ΑΛΛΙΩΣ_ΑΝ Μ[i] <= 2000 ΤΟΤΕ
ΝΜ[i] Μ[i] - Μ[i]*(9/100)
                                  ΑΛΛΙΩΣ_ΑΝ Μ[i]  >  2000 ΤΟΤΕ
 ΝΜ[i] Μ[i] - Μ[i]*(11/100)
                                  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ  
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
                      ΑΝ Π[i]>3 ΤΟΤΕ
ΓΡΑΨΕ O[i],”Πολύτεκνος δεν πραγματοποιήθηκε μείωση αποδοχών”
            ΑΛΛΙΩΣ
ΜΕΙΩΣΗ  Μ[i] - ΝΜ[i]
                    ΓΡΑΨΕ “Οι νέες αποδοχές του”, O[i],”είναι”, ΝΜ[i]
                    ΓΡΑΨΕ “Πραγματοποιήθηκε μείωση”, ΜΕΙΩΣΗ,” € στις αποδοχές”
            ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ