Υποπρογράμματα - Άσκηση 1 - Εύρεση μεγίστου/ελαχίστου και των θέσεων τους με υποπρόγραμμα

 
Να γράψετε υποπρόγραμμα το οποίο για οποιοδήποτε πίνακα 100 ακεραίων στοιχείων υπολογίζει και επιστρέφει το μέγιστο, το ελάχιστο και τις θέσεις αυτών.
 
Λύση: 
ΔΙΑΔΙΚΑΣΙΑ MAX_AND_POSITIONS (A,  MAX, POS_ΜΑΧ, ΜΙΝ, POS_MIN)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ : Α[100] ,ΜΑΧ, POS_MAX, MIN, POS_MIN,Ι
ΑΡΧΗ
ΜΑΧ Α[1]
POS_MAX 1
MIN  A[1]
POS_MIN 1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 100
ΑΝ ΜΑΧ < Α[Ι] ΤΟΤΕ
ΜΑΧ Α[Ι]
POS_MAX I
ΤΕΛΟΣ_ΑΝ
ΑΝ MIN > Α[Ι] ΤΟΤΕ
MIN Α[Ι]
POS_MIN I
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ