Υποπρογράμματα - Άσκηση 2 - Αναζήτηση με υποπρόγραμμα

 
Να δημιουργηθεί υποπρόγραμμα το οποίο δέχεται ως παραμέτρους έναν πίνακα 50 στοιχείων τύπου χαρακτήρα και μια τιμή που αναζητά ο χρήστης και επιστρέφει την τιμή ΑΛΗΘΗΣ αν υπάρχει το στοιχείο στον πίνακα ή την τιμή ΨΕΥΔΗΣ αν δεν υπάρχει.
 
Λύση: 
ΣΥΝΑΡΤΗΣΗ FIND (X, KEY) : ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ : Ι
ΧΑΡΑΚΤΗΡΕΣ : Χ[50], KΕΥ
ΑΡΧΗ
FIND  ΨΕΥΔΗΣ
Ι ← 1
ΟΣΟ FIND = ΨΕΥΔΗΣ ΚΑΙ I <= 50 ΕΠΑΝΑΛΑΒΕ
ΑΝ Χ[Ι] = ΚΕΥ ΤΟΤΕ
FIND ← ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
Ι ← Ι + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ